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~fu~a~o~d~u~cl~ro~n~ ________________ ~ 

1-2 

The Pyware™ Instrument Designer is designed to make use of 
the AppleliGS ensoniq chip and the Pyware Music Writer. With 
the Pyware Instrument Designer and the ApplellGS, you can 
create any instrument sound you wish, Alter sound waves, 
control sound attacks, sustains, decays, vibratos, pitch bends 
and much more. Create anything from acoustic instruments to 
your own original sounds. 

The PywareTN Instrument Designer is also an excellent teaching 
and learning program for teachers and students in Music or 
Science. It allows you to both SEE and HEAR how modifications 
to sound waves affect the sound. 

Owners of the Pyware™ Music Writer can also benefit from the 
Instrument Designer. The Instrument Designer enables you to 
create unlimited libraries of sounds that can be used with the 
Music Writer to aid in music composition and notation. 

/\ 

After reading this chapter. Begin learning about the Instrument 
Designer by reading through Chapter 2. This chapter explains 
different techniques for modifying sound waves. It is important to 
understand these techniques to help you produce the best 
sounds. The remainder of the manual covers each feature. You 
can read the features now or refer to the manual as necessary 
during a session. 

-,-Wha=""t y~o=u~n~e~ed~to~s~ta~trt~ __________ ~ 

• 
• 
• 

Apple IIGS with at least 512K 
Instrument Designer Program disk 
Manual 
At least 2.0 ROM update for AppleliGS 
~: If the first three digits of your computer serial 
number are less that 704 then you probably need the 
2.0 update. If you do not have the update, the 
Instrument Designer will give unpredictable results. Your 
local Apple dealer can inStall this update for you at little or 
no charge. 

Optional 
• MIDI Interface or MIDI box with a synthesizer 
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",-Firs~' -"!t!'-.!>b""a~ck",-,u~p~yP!o~ur~dis~· ks~ _____ ~ 
Before you begin. back up your disks. Use any copy program to 
copy the program and data disks to blank disks (see note below). 
Use the copies and store the originals in a safe place. 

/1.Qm: Back up your data disk frequently after you begin 
designing. Although not a common occurrence floppy disks can 
be damaged. 

~C=~=t=o=m=e~r=Su~p~PQ~rt~ ____________ ,~ 

1-4 

Pygraphics welcomes the opportunity to talk with you about any 
matters concerning computers and education. Should you have 
any need concerning your software. we are ready. If you have 
any suggestions on software updates. we want to hear them. 
Please call usl Our number is (817) 481-7536. 

If you want to use a hard disk with the Instrument Designer. see 
the Appendix in the back of this manual. 

Chapter 2 
Sound Wave Science 
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~H~o-.!!w~In~st!!!crum~~en~t!!..:!D!:!Ce~s~ign~e~r.J.Wuol!,r~k~s __ ~ 
The Instrument Designeruses graphic windows to modify sound 
waves. The windows include Vibrato, De-Tuning, Envelope, and 
the graph of the actual sound wave. By using these windows you 
can dramatically alter the way a sound wave is heard. 

Vibrato. With the Vibrato window you can cause the pitch of the 
sound to pulsate. A characteristic heard in many musical sounds. 
The vibrato (pulsation) intensity as well as the vibrato speed can be 
changed. 

De-Tuning, An instrument sound on the instrument designer 
actually consists of two sound waves, usually looking exactly the 
same and played exactly at the same time. However, since there 
are two distinct waves you can do several unusual things. You can 
tune one wave slightly off from the other wave. This causes an 
intonation wavering that is commonly heard in instruments. 

Envelope. A sound can be dramatically altered by changing the 
. ASRD. ASRD refers to the instrument Attack, Sustain, Release 
and Decay. The Envelope consists of 8 segments. The slope 
between the first and second segment usually indicates the attack. 
The slope between the second and third segment usually 

indicates the Sustain, 

c Envelope 

sustain -LL..-r 

and likewise wtth the 
Release and Decay. 
The envelope is the 
most significant 
window for attering the 
way a sound is heard . 
For example, a 
substantial increase in 
the slope of the attack 
of a flute will make the 

attack 
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flute sound like a bell. 

Sound Wave. The sound wave window is used to draw and edit 
a sound wave pattern. You can edit or draw on either wave A or 
wave B or both simultaneously. (Remember, two waves are used 
as explained in De-Tuning above) 

=S=oun~d~D=e~~~'gn~M~e~ili~~~ _________ ~ 
There are usually two ways digitized sounds are used. Rrst, a pure 
sound wav.e played completely through one time, and second, 
only a section of a sound wave consisting of the sustained portion 
of the wave played repetitively throughout the length of a note. 

One Shot Mode 

The first type (pure sound wave) takes alet of memory to store the 
sound ~ave. When the wave is played you will hear a vel)' close 
approximatIOn to the true sound. Below is a picture of a sound 
wave. Notice the different phases of the wave (attack, sustain, and 
decay). 

note was released here J (raleu8 segment) 

~ _. - ....... , __ .1_. ---...,..--_. 
attack .ustaln decay 

In ONE SHOT MODE an entire wave is played from beginning to 
end one time. The wave should contain the three phases shown 
above to sound good. The sound waves are usually large in size 
(32768 bytes). Sound waves played in one shot mode have the 
best quality. 

The only draw back to this type of sound wave is that you can only 
play the wave through one time for evel)' note, otherwise you 
would replay the attack,sustain and decay many times as shown on 
the next page. 

2-3 



2-4 

attacksustain decay 

Repeating a sound wave that contains , 
an attack sustain and decay as shown here ~ 
would make a sound that looks like this. __ -.... 

I 

Such sound waves are better played in ONE SHOT mode. The 
ONE SHOT mode appears in the OPTIONS menu of the program 
under Play Mode. The ONE SHOT mode plays the sound wave 
only one time through. This is a good technique to use for 
instruments that do not sustain. For example, a piano has the same 
note length regardless of how long you hold down a piano key, 
whereas a trumpet note can be held many times longer. When you 
want to hold a note for an instrument such as a trumpet the ONE 
SHOT mode would be a poor choice. To sustain a note for an 
instrument like a trumpet, you would need to choose the LOOPED 
mode. 

Looped Mode 

Before we show you the LOOPED technique, lets first diasect the 
sound wave used in the previous example. The complete sound 
wave was divided into three main parts. The attack, the sustain, and 
the decay. And you saw how looping a wave with all three parts 
would produce a sound with many repeating attacks, sustains and 
decays. However, what if we just picked a single part of the sound 
wave, which part would you pick? H the sound wave were a trumpet 
and we picked the attack, the sound would be the trumpet players 
tongue starting the note with a 'a' sound. H that part of the wave 
was repeated over and over to create a long sound it probably 
would not sound Uke a trumpet player holding the note for a long 
lime. It would sound more Uke a trumpet player attacking many 
notes over and over very fast. 

What if we picked the sustain part of the sound to repeat (loop) 
instead of the attack part. Playing this part of the sound wave over 
and over again would sound more like a trumpet player holding a 
note for a long time. This is because the sustain is the part of the 
sound wave that you hear when a trumpet player holds a note. 

sustain part of 
the sound wave 

sustain portion cut out 
and looped when played 

Note: A looping sound wave should be short waves because even 
the sustain part of a sound will change through a long sound 
sample and when looped will have a quivering sound as it loops 
from the end of the wave back to the beginning of the wave. Keep 
wave samples under 1024 bytes for best results. 
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If we repeat the sustain part of the sound wave over and over there 
will not be a real sounding attack to the sound. Therefore the 
sound still does not sound like a true trumpet player. This is where 
the enve/Qpe window is best used. Since we have determined that 
the sustain portion of a sound wave is the best part to repeat, we 
must now try to make the sustain part of the wave sound tike an 
attack when first started. With the envelope we can control the 
volume of a sound wave throughout the duration of the sound. 
Therefore we can make the attack much louder than the sustain 
part oOhe sound and make the looping wave simulate an attack. 

austaln 

attack 

D Envelope 

The Envelope feature is found in the program on the Windows 
menu. 

Notice the above example, there are eight small squares on the 
envelope graph. These squares are called handles. The handles 
are used to move the graph and change the slope between the 
graph segments. As you see, the attack slope is very steep. This 
steep envelope will cause a very sharp attack tike the sound of a 
bell. 

Now look at the decay. There are two segments used in this 
example for the decay. The first segment has a steeper slope than 
the second. This example will first decay to a' medium volume fairly 
fast and then decay down to nothing more slowly during the last 
segment. 

The last 4 handles are not used in this example , so they are moved 
to the bottom of the envelope window. 

Combination of both wave types 

There is another technique of sound design that uses both types 
of sound waves. This mode is called ONE SHOT A & LOOPED B. 
In this technique two different waves are used. The first wave is 
played through one time and then the second wave is repeated 
until the note is released. 

ONE SHOT A & LOOPED e 

Wave A is only the Attack part of a sound and Wave B is the sustain 
part of the sound. As you see, this eliminates the need for the 
envelope to simulate an attack as used in the previous section. 
With this setup only Wave B is used during the sustain. Whereas 
the other two techniques use both Wave A and Wave B to contain 
the same wave played paralled giving you double the intensity of 
the sound. 
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~Th~e~Fil~'e~M~en~u~ _______________ ~ 
The File Menu contains all of the filing and saving functions of the 
program. These features are: 

New. . . . . . . . Creates a new sound file in memory. 

Open. . . . . . . Reads an existing sound file from a disk and loads 
it into memory. 

Close. . . . . . . Removes an existing sound from the computers 
memory. 

Save . . . . . . . . Writes a sound file that is in the computers 
memory back to a disk. 

Save As . . . .. Writes a sound that is in the computers memory to 
a disk and allows you to enter a new name for the 
sound. 

Get Wave File .. Reads a Wave File into the Sound Wave window, 
keeping the other window settings unchanged. 

Librarian. . .. Moves a Sound File into a Sound Ubrary. The 
Sound Ubrary is a collection of sound files that will 
load into the Pyware Music Writer. 

Qull. . . . . . . . . Leaves the program. 

=N~e~w~c=om==m=a=n=d=-________________ ~ 
The New command creates a new sound file in memory and 
displays it on the screen. If there is already a sound file displayed on 
the screen the New command will not operate until the file has 
been Closed. To operate the New command: 

1 Move the mouse pointer to the menu item File. 
2 While holding the mouse down, drag the mouse to the New 

command on the File menu and release. 
3 A new sound file will be displayed on the screen. 

=O~p=en==co=m~m=an~d _______________ ~ 
The Open command loads an existing sound file into memory 
from a disk. If there is already a sound file displayed on the screen 
the Open command will not operate until the sound file displayed 
is Closed. To operate the Open command: 

1 Move the mouse pointer to the menu item File. 
2 While holding down the mouse button, drag the mouse to the 

Open command. 
3 An Open dialog box will display: 

Open which Sound file? 
C IHd201SoundFilas 

C Electric Bass 
D Flute 
tl Guitar 
D Weird 

Disk 

0'. 
Cancel 

Sound File list 

Disk - changes the disk that is 
looked at when the tist of sound files 
is displayed 
Open - opens the file that is 
highlighted on the list of sound files. 
Close - closes the file or folder that is 
highlighted on 
the list of sound files. 
cancel - returns to the main screen 
without doing anything. 

4 Click on the sound file that you want displayed and click the 
Open button. 
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~C~w~s~e~c~o~nun~~an~d~_______________~ 
The Close command removes an exisling sound file from 
computer memory. If there is no sound file displayed. the Close 
command will not operate. If there has been a change made on the 
sound file displayed. you will be asked if you want to Save the 
sound file to a disk before closing ij. To operate the Close 
command: 

1 Move the mouse pointer to the menu item Close. 
2 While holding down the mouse button. drag the mouse to the 

Close command. 
3 If there have been any changes made to the sound file while it 

has been displayed. you will be asked if you want to save the 
file before closing. 

If you choose YES and the file has not yet been named a save 
dialog box will display as shown in the next section. 

~S=a~ve~co~nunan~~~d ________________ ~ 
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The Save command writes a sound file that is in the computers 
memory back to the disk. If there is no sound file displayed on the 
computer the Seve command will not operate. If the file is untitled 
you will be prompted to enter a file name before saving to a disk. To 
operate the Save command: 

1 Move the mouse pointer to the menu item File. 
2 While holding the mouse button down. drag the mouse to the 

Save command on the File menu and release. 

(continued next page) 

3 If the file is untitled a Save dialog box will display. 

~ICJI -:;:;;::;;;----l .... U'I"K - changes the disk that is 

[J FI"o displayed ~'~";' ~~~i=r2~~~~_ looked at when the Ust of files is 
C Electric Bass 
[J TomToms New folder - creates a new folder 
[J Wlor. for the new sound file 

Open - opens a folder 
Close - closes a folder 
Save - writes the sound file to the 
disk 

New file name 
List of flies and laird",·" 

cancel - retu ms to the 
main screen 

4 Type the new file name and click the Save button. 

=S=av~e~As~c~o~nun~~an~d ______________ ~ 
The Seve As command writes a sound file that is in the computers 
memory to a disk while allowing you to change the name of the 
sound file. To operate the Save As command: 

1 Move the mouse pointer to the menu item File. 
2 While holding the mouse button down. drag the mouse to the 

Save As command on the File-menu and release. 
3 A save dialog box will display as shown on previous page. 
4 Type in the new name for the file and click the Save button. 
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~Ge~tW~a¥~e~Fil~'~e ________________ ~ 
The Get Wave File command is used to load a wave file into the 
Sound Wave window. Donl confuse a 'Wave file' with a' sound file'. 
A wave file is a binary file that only contains a wave table. A sound 
file is a file that contains a wave table and all other information such 
as the envelope, vibrato, relative pitch, etc. Sound files are loaded, 
saved and created with the Open, New,Save, and Save As 
commands on the File menu. Wave files are created by other 
programs such as samplers and can be loaded into the Instrument 
Designervia the Get Wave File command. To use the Get 
Wave File command: 

1 Open a sound file whose Envelope, De-Tuning, Vibrato, and 
Relaijve Pitch is something that you want. If you want the 
default seWngs for these, select New from the File menu. 

2 Select Get Wave File from the File menu. 
3 A dialog window will display asking whether you want this wave 

file written to Wave A, Wave B or both Wave A & B. 
4 A dialog window will display giving you choices of files that you 

may want. After choosing a file, the wave table will be loaded 
into wave A anellor wave B. 

~U~brnrnm~' ~ ___________ ~ 
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The Librarian is used to move sound files into a collection of 
sounds called a sound Pbrary. Sound Libraries are used with the 
Pyware™ Music Writer. H you do not own the Pyware Music Writer 
this feature is not of any use. To operate the 6brarian: 

1 Select Librarian from the File menu. 
2 A Librarian dialog window will display. As shown on the next 

page. 

3 

4 

5 

Cfick on an instrument that you want in the library. 

Pywa,. Inatrument Librarian 

HD20\Sounda\ Untit'-d 

Flute r ( ,.,,.Install» ) 
Clarinet 

"" ( « Extract« ) 

"""" Bird ( 
"'" 

Delete Instrument ) 

v~t 
( Open Anotha, Librarr ) 

( Quit ) f-

For exam Ie the trum et sound. p p 

Click the Install button and a copy of the sound will be written 
into the sound library. 
Repeat steps 2 and 3 until all sounds that you want are in the 
library 
Select Quit and you will be asked whether you want to save 
the library file. Choose YES and enter a new sound library file 
name. 

Other Qpljons; 

Extract - Moves a sound file out of the sound library (right side) to 
the sound files list (left side). To use, click on the sound in the 
library (right side) you want extracted, then cUck Extract. 

Delete Instrument - Removes an instrument from the sound 
library (right side). To use, click on the sound in the library (right 
side) you want deleted, then click Delete Instrument. 

Open Another LIbrary - Saves the current library on the right 
side (if any) and displays an Open dialog window for you to choose 
another Ubrary to display. 
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~Q~w='t~c=o=nnn==an==d~ ______________ ,~ 

3-8 

The Quit command leaves the program. H you have a sound file 
that you have made a change on and you have not saved ~, you will 
be prompted to save the file before quitting. 

1 Move the mouse pointer to the menu item File. 
2 While holding the mouse button down, drag the mouse to the 

Q!Jlt command on the File menu and release. 
3 If there is a sound file displayed on the screen with changes 

that have not been saved, you will be prompted to save the file 
before quitting. 

Chapter 4 
The Edit Menu 
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~Th~e~EMmU·t~M~e~n~uL-_______________ ~ 
The Edit. menu is used to edit sound waves. With the Edit menu 
you can delete portions of a wave as well as cut, copy and paste 
portions of a sound wave using the cUpboard. The c/lbboard is a 
temporary memory location that will hold copies of a sound wave for 
duplicating and moving. 

CU: ............ This function cuts a selected range from the 
• sound wave in the sound wave window and saves 

the cut selection in the cUbboard for future use. 

4·2 

Copy . . . . . . . .. This function makes a copy of a selected range of 
a sound wave in the sound wave window and 
saves the copy in the clipboard for' future use. 

Paste ......... This function takes a sound wave that is stored in 
the cUpboard and inserts it into the sound wave in 
the sound wave window at the marked position. 

Delete ........ This function deletes a selected range from the 
sound wave in the sound wave sindow. 

The Clipboard is a memory location that is used to store temporary 
copies of a sound wave so that you can relocate the wave at a new 
position. For example to copy the attack of WaveA to the 
beginning of Wave B you would: 

1 Set the mode on the sound wave window from Draw to 
Select. 

2 Select wave on the sound wave window to be Wave A. 
3 Use the mouse to drag through (or select) the beginning range 

of the sound wave. It will become inverted indicating that it is 
selected. 

4 Choose Copy from the Edit menu. This will make a copy of 
the selected range into the clipboard. 

5 Switch to Wave B on the Sound Wave window. 
6 COck on the beginning of the sound wave to indicate the 

insertion point. 
7 Choope Paste from the Edit menu. This will make a copy of 

the clipboard into Wave B at the insertion point. 

=Se~l~~tin~g~r.m~g~es~ _____________ ~ 
Before you can edit with the clipboard, you must first select the 
range on the wave file you want to copy, cut and paste. Selecting 
ranges is possible with the Sound Wave window. The picture 
below shows steps for selecting a range. 

Choose the wave you want to copy, cut, or 

the mouse, drag from the beginning to the ending 
of the range you want to select 

4·3 



The steps for selecting ranges are: 

1 Choose the sound wave you want by clicking Wave A or 
Wave B from the Sound Wave window. You cannot edit 
from Wave A and Wave B at the same time, so the Wave 
A&B option is not a valid option from the Sound Wave 
window for selecting ranges. 

2 Click on the Select buttonon the Sound Wave window to 
indicate that you are going to be selecting a range. 

3 With the mouse move to the beginning of the sound wave 
range you want to select. 

4 While holding down the mouse, drag the mouse to the end 
of the sound wave range you want to select. The selected 
porlion will be highlighted. (Note: There are several keys 
that are usefull for selecting ranges when your range will not 
all fit on the window. These keys are covered next.) 

Selecting Bange Shortcut Keys 

4·4 

To select from a chosen point to the END of the wave, hold 
down the Command key while clicking on the beginning of the 
range with the mouse. 

To select ranges larger than the Sound Wave window. 
1 Select the beginning of the range with the mouse. 
2 Scroll to the wave portion that contains the end of the 

selection you want. 
3 Hold down the .s.tJiIt key while clicking on the ending position 

with the mouse. 

To select a range from the BEGINNING to a chosen point, hold 
down the .s.tJiIt key while clicking on the ending of the range with 
the mouse. 

To EDIT a selected range, hold down the .s.tJiIt key while clicking 
on the new beginning or ending range with the mouse. 

~C~u~t~c~om~m~a~n~d~ ________________ ~ 
The Cut command removes a selected portion of a sound wave 
and places the cut portion in a temporary storage location called 
the clipboard. To use the Cut command: 

1 Choose which wave you want to cut from, and click on the 
wave choice in the Sound Wave window. Valid wave choices 
are Wave A and Wave B. (If the Wave button is already 
highlighted, you don't have to click it again.) 

2 Click on the Select button in the Sound Wave window. 
This will indicate to the program that you want to select a 
range from the sound wave. (If the Select button is already 
highlighted, you donl have to click on it again.) 

3 Move the mouse to the BEGINNING of the porlion of the 
sound wave that you want to cut. 

4 While holding down the mouse, drag the mouse to the END 
of the portion of the sound wave that you want to cut. (See 
Selecting Range Shortcut Keys, earlier in this chapter for 
more flexability in selecting ranges) 

5 Choose Cut from the EdIt menu. The selected range of 
the sound wave will be deleted and copied to the temporary 
storage location called the clipboard. 

~C~o~p~x~c~omm~~an~d~ _____________ ~ 
The Copy command makes a copy of a selected portion of a 
sound wave and places the copy in a temporary storage location 
called the clipboard. To use the Copy command: 

1 Choose which wave you want to copy from, and click on the 
wave choice in the Sound Wave window. Valid wave choices 
are Wave A and Wave B. (If the Wave button is already 
highlighted, you don't have to click it again.) 

2 Click on the Select button in the Sound Wave window. 
This will indicate to the program that you want to select a 
range from the sound wave. (If the Select button is already 
highlighied, you don't have to click on it again.) 

3 Move the mouse to the BEGINNING of the portion of the 
sound wave that you want to copy. 
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4 While holding down the mouse, drag the mouse to the END 
of the portion of the sound wave that you want to copy. (See 
Selecting Range Shortcut Keys, earlier in this chapter for 
moreflexability in selecting ranges) 

5 Choose Copy from the Edit menu. The selected range of 
the sound wave will be copied to the temporary storage 
location called the clipboard. 

=P=a=st=e~C=O=riun===an=d=-_______________ ~ 
The Paste command moves a copy of the wave selection in the 
clipboard into the sound wave at your chosen poSition. To place 
a wave selection into the clipboard you must first have used Cut 
or Copy. To use Paste: 

1 Choose which wave you want to cut from, and click on the 
wave choice in the Sound Wave window. Valid wave choices 
are Wave A and Wave B. (If the Wave button is already 
highlighted, you don1 have to click it again.) 

2 Click on the Select button in the Sound Wave window. 
This will indicate to the program that you want to select a 
range from the sound wave. (If the Select button is already 
highlighted, you don't have to click on it again.) 

3 Move the mouse to the BEGINNING of the portion of the 
sound wave that you want the clipboard inserted. 

4 Choose Paste from the Edit menu. A copy of the clipboard 
will be inserted into the poisiton indicated. 

~D=e=le=te~c=o=nun===an=d=-_____________ ~ 
The Delete command removes a selected portion of a sound 
wave. To use the Delete command: . 

1 Choose which wave you want to delete from, and click on the 
wave choice in the Sound Wave window. Valid wave choices 
are Wave A and Wave B. (If the Wave button is already 
highlighted, you don't have to click it again.) 

2 Click on the Select button in the Sound Wave window. 
This will indicate to the program that you want to select a 
range from the sound wave. (If the Select button is already 
highlighted, you don't have to click on it again.) 

3 Move the mouse to the BEGINNING of the portion of the 
sound wave that you want to delete. 

4 While holding down the mouse, drag the mouse to the END 
of the portion of the sound wave that you want to delete. 
(See Selecting Range Shortcut Keys, earlier in this chapter 
for more flexability in selecting ranges) 

5 Choose Delete from the Edit menu. The selected range 
of the sound wave will be deleted from the sound wave. 
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The Windows menu is used to display each of the graphic windows 
that are used to modify a sound. The windows include: 

Sound Wave. .. Displays the actual sound wave. The sound wave 
can be edited through this window. 

Keyboard . .. Displays a piano keyboard so that the user can test 
his sound by selecting different notes from the 
keyboard. 

Envelope. .. Displays the envelope where the attack, sustain, 
release and decay of a sound can be a~ered. This 
will greatly change the way a sound will be heard. 

Vibrato ....... Displays the vibrato window. This window can 
change the speed and depth of a vibrato or 
pulsation of a sound as it is played. 

De-Tuning.. Displays the De-Tuning window. Two copies of a 
sound wave are usually played simu~aneously 
(Wave A & Wave B). This window can change the 
pitch of one of the waves in very small increments. 

Volume ...... Displays the Volume window. This window 
changes the playing volume of the sound while 
you are testing it. There is also a STOP button 
used to stop the sound if you cause an infinite 
loop in the envelope. 

The Sound Wave window displays the actual sound wave. The 
sound wave can be edited through this window. 

chooses which wave draw mode select mode 

wave form area 

Choosing Wave A or B 

Sounds on the Apple IIGS normally use two sound waves that are 
identical. When both are played simu~aneously the AppleliGS has 
a richer sound. Using two waves also gives you more flexibility in 
what you can do with the sound. For example two differenlwaves 
played simu~aneously give inlresting results. You can also make 
the pnches of the two waves slightly different to give the sound 
more depth. As shown above, you can display wave A, by clicking 
the Wave A box found just under the Title line. Clicking Wave B will 
show only wave B and clicking Wave A&B will show both wave A 
andB. 
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prawlng on the wave 

If you want to edit the shape of a sound wave, you can do it with the 
mouse. To Draw: 

1 Click on the Draw box. 
2 Click on the wave that you want to draw on a portion of. (Wave 

A, Wave B, or Wave A&B) 
3 Move the mouse to the start of the sound wave portion you 

want to change. 
4 Drag the mouse to draw the new shape of the wave form. 

Selecting ranges to edit 

If you want to copy portions, delete portions, or move portions of a 
wave you will use the Select button to select ranges of the wave 
forthe edit operation. To Select: 

1 Click on the Select box. 
2 Use the mouse to drag through the range you want to edn. 
3 Choose an edit function from the Edit menu. 

More details on editing waves are found in Chapter 4 - The Edit 
1lliI.!lU.. 

The Keyboard window displays a piano keyboard so that the user 
can test his sound by selecting different notes from the keyboard. 
To use the Keyboard window: 

1 Move the mouse to the note on the keyboard that you want to 
play. 

2 Hold down the mouse to play the note. 

~E~n~ve~l~ope~W~m~d~own-_____________ ~ 
The Envelope window displays the envelope where the attack, 
sustain, release and decay of a sound can be altered. This will 
greatly change the way a sound will be heard. 

[] Envelope 

sustain -++-" 
attack 

release segment 
decay 

The small boxes found in the window are called handles. These 
handles are used to move the envelope slope lines. The example 
above has a strong attack, the sustain is the part of the envelope 
that is horizontal (no slope). The release segment is the point in 
the envelope that is jumped to when you release the note on the 
keyboard. After the note is released, it decays quickly and then 
slows down until the sound is gone. As shown, the decay is in two 
segments. The first wnh a fast slope and the second a slightly 
slower slope. 

InfinIte loops or SustaIn loops: When you release your note on 
the keyboard the the sound will jump to the part of the envelope 
that is called the release segment. If there is a segment after that 
point that has no slope (horizontal) the sound will stick at that point. 
This is called an infinite loop. You rarely want this but since 
someone might want a sound to do this we have made ij possible. If 
your sounds stick in an infinite loop and you want them to stop, 
there is a STOP button provided in the volume window. Just click 
on the STOP button and the sound will quit. 
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Lowest positIon you can move a handle: If you place a segment 
handle at the bottom of the window the sound will stop at the end of 
that segment regardless of any other segments positions past that 
point. This is why you cannot move a handle to the bottom of the 
envelope untill all segment handles past that point are at the 
bottom also. To get around this, simply move handles to the 
bottom of the window starting with the LAST handle in the 

Envelope Examples 

The next few pages contain several Envelope Window examples. 
It is recommended that you review these examples to fully 
understand the envelope and how to make setting adjustments. 

Example Envelope #1 

4--11-- fast drop off alter attack 

sustaining part of sound 
(horizontal lines always sustain) 

I 

release segment 

Notice the sustaining part of the sound. This is called the 
'sustain loop'. It is created by placing two handles that are 
next to each other at the same horizontal level (volume). 
This is the part of the wave where the sound volume 
STICKS. When you release the note the sound volume 
will continue to the part of the envelope that is called the 
'release segmenf. As you see the release segment is 
AFTER the sustain loop. The sound volume will now travel 
through the remainder of the envelope through the part that 
is labeled 'moderate decay'. 

mild 
attack 

Example Envelope #2 

_--r-- practically no drop off alter attack 
I 

sustaining part 01 sound 
(horizontal lines always sustain) 

I 
long decay 
after note is released 

sharp 
attack 

release segment 

Example Envelope #3 

fast drop off after attack 

release segment 

NOTE: Unlike examples 1 & 2, there are no sustaining 
segments (sustain loops) to the wave. Sustain loops 
are made by putting two adjacent handles together at 
same vertical level (volume). This example will not 
sustain. Non-sustaining envelopes are good lor 
instruments such as guitars, pianos and bells because 
these instruments are unable to sustain for long times. 

The release segment is at the end of the envelope. This 
is when a note is released the sound volume will jump 
directly to that part of the envelope. 
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sharp 
attack 

drop off after attack 

5-8 

release segment 

f 
sustain 
loop 

After the note is attacked and the volume begins dropping 
off it will STICK at the sustain loop. The sustain loop will 
hold the note. When the note is released. the sound 
volume will jump back to the release segment point of the 
envelope and play back to the STICK paint again. This 
note. therefore. will never stop unless you press the STOP 
button on the Volume window. 

sharp 
attack 

release segment 

Example Envelope #5 

drop off after attack 

sustain loop 

This example is exactly the same as example #4. except 
the release segment has been moved. The release 
segment is now AFTER the sustain loop. The sustain loop 
is the horizontal part of the envelope. Now as the sound 
volume follows the envelope graph. the sound volume 
STICK at the sustain loop. causing the sustained part of the 
note. When the note is released the sound volume will set 
to the release segment point of the envelope and continue 
down the decay until the sound volume is O. 
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sharp 
attack 
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sustain loop 

release 
segment 

this shaded portion will not play 

The shaded portion of this envelope will NEVER play 
because of the location of the sustain loop and release 
segment. The sound volume will follow the envelope to the 
sustain loop where it will stick creating the sustain portion 
of the note. When the note is released the sound volume 
will jump to the release segment and follow the remainder 
of the envelope to the end. Therefore, the shaded portion 
of the envelope will never be played. 

~V=ili=r=aro~vnn~'=d=o=w~ ______________ ~ 
The vibrato window can change the speed and depth of a vibrato or 
pulsation of a sound as it is played. 

D Vibrato 
control 
handle --t-"\ 

11 t 
vibrato 
'Peed 

I·,· .. to 
depth 

The control handle is used to change the vibrato. Moving the 
handle UP will increase the depth of the vibrato. Moving the handle 
left will decrease the speed of the vibrato (pulsation). 

=D=e.~T=wmn==·~g~W~in=d=o=w~ ____________ ,~ 
Two copies of a sound wave are usually played simunaneously. 
This window can change the pitch of waves in very small 
increments. This causes a slight intonation waver that is commonly 
heard in some instruments. 

[J D.~Tunln 

1
112 step aharp 

in-tune 

The handles are used to change the pitch of one of the two waves. 
Wave A is on the left and Wave B is on the right. As you drag the 
handle up the pitch raises up to 112 step from the Original pitch. 
When the handle is at the bottom, the pitch is set to correct pitch. 
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The volume window is used to change the volume of the keyboard 
when you test sounds. There is also a STOP button to stop a 
sound that is infinitely playing due to an envelope segment set with 
no slope. (sustaining pitch) 

o Volume stop 
.. ounel 
button 

Volume: Use the volume handle to adjust the volume. Moving it up 
wiD increase the volume and moving it down wiD decrease the 
volume. 

Stop button: If you should create an envelope that has an infinite 
loop (see Envelope Window). Clicking on this button will stop any 
infinite sounds. 

Chapter 6 
The Envelope Menu 
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~Th==e~E=n~¥~cl=o~p=e~M=e=n=u~ ____________ I~ 

The Envelope menu contains features used to modify the 
Envelope Window. 

Snapshot Envelope .... Takes a picture or snapshot olthe 
current Envelope window. 

Revert to Snapshot. . .. Replaces the current Envelope 
window with the window that is in the 
snapshot. 

Exchange Envelope .... Switches the envelope that is 
currently displayed in the Envelope 
window with the envelope that is in 
the snapshot. 

For more information about the envelope, see Envelope 

Window in Chapter 5. 

=Sna~p=Sh=o=t=En==ve=l~ope~ ____________ ,~ 

6·2 

This options takes a picture or snapshot of the current Envelope 
window. This is useful ~ you flke the wayan envelope is set but you 
want to experiment with a few changes. II your changes are not as 
good as the envelope snapshot, you can revert back to the 
snapshot. This way you don't have to try to re-make a envelope 
selting you liked if you experiment with new settings. To use this 
command simply select it anytime you want a snapshot made 01 the 
envelope. 

=Re=¥=e=rt~~=o~~==~ps=b=o~t _____________ ~ 
This option is used in conjunction with Snapshot Envelope. 
See Snapshot Envelope above. To use this command simply 
select it when you want the envelope reverted back to the 
snapshot envelope. 

=E=xc=b=a=n~ge~Sna~p=s=ho=t~ ___________ ~ 
This option operates like Revert to Snapshot except the 
current Envelope window settings are exchanged with the 
Envelope Snapshot. The Snapshot values will then be displayed 
on the Envelope window and the Settings in the Envelope window 
will be placed in the snapshot. 

This is handy ~ you take a snapshot of an envelope selting you Uke, 
then you experiment with the envelope. After experimenting you 
want to hear which envelope you like best. You can exchange the 
two envelopes back and lorth and hear each 01 them to choose 
which one is best. 
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The Options Menu 
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The Options menu contains the following: 

100% Wave .. Displays a sound wave in 100% mode. This 
means that each pixel across the screen is one 
data byte. 

Size To Fit ... Displays a sound wave in Size To FIX mode. This 
means that the entire wave. regardless of its size is 
compressed to fit within the width of the sound 
wave window. 

WaveSlze .. , Changes the storage size of the sound wave. 
You can change the size of Wave A and Wave B 
independently. 

Relative Pitch . Changes the pitch played when a key is pressed 
on the keyboard. Shifts all notes up or down the 
amount chosen. Increments are in 1/2 steps. 

Play Mode ... Changes the method (or mode) in which the 
sound waves are played. 

These options change the way in which a wave is displayed on the 
Sound Wave window. If you choose 100% Wave. the wave will 
draw on the window where each pixel (screen column) represents 
1 byte in the wave. If you choose Size To Fit. the wave will be 
drawn compressed so that the entire wave will In within the border 
of the Sound Wave window. 

~W~a=ve~S=Ue~op~ti='o=n~ ______________ ~ 
The Wave Size option is used to change the length of the wave 
sample in the Sound Wave window. You can change the length of 
the two waves Wave A and Wave B independently. 

Note: Indepentent wave size control is useful when you are using 
a Play Mode called ONE SHOT A & LOOPED B. In this mode the 
first mode is played one time through first (the attack of the wave) 
and the second wave is looped to play the sustaining part of the 
sound. Your choices are from 256 bytes to 32k. The larger the 
wave the better the quality of sound. The smaller the wave the 
more that will fit into a sound library. See the chapter on Sound 
Wave Science to help you detennine the correct sound wave size 
to choose. 

Way. A Way. B 

• 256 bytes 
o 512 bytes 
o 1024 bytes 
o 2048 bytes 
o 4096 bytes 
o 8192 bytes 
o 16384 bytes 
o 32768 bytes 

• 256 byte. 
o 512 bytes 
o 1024 bytes 
o 2048 bytes 
o 4096 bytes 
o 8192 bytes 
o 16384 bytes 
o 32768 bytes 

( Q( ) 

To select a sound wave size click on the desired button and click 
OK. 
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The Relative Pitch options is used to change the note played 
when a note is pressed on the keyboard. A Sound wave is 
recorded at a certain pitch. This pitch is cailed the true pitch of the 
sound wave. This feature will adjust the true pitch so that all notes 
are offset by the value indicated. 

Relative Pitch 

Wave A Wave B 

Octave " Octave " 
Note 11 NOle 11 

~ ~ 
( Q( ) 

There are two slide scales on the Relative pijch window, one for 
wave A and one for wave B. You can adjust the relative pitch of the 
waves independently with these slide scales. 

If you move the sUde up, the note offset will go up therefore playing 
higher notes. If you move the slide down, the note offset will go 
down therefore playing lower notes. 

If the offset indicators located above the sUde are positive numbers 
the offset is above the true pitch of the sound. If the offset 
indicators are negative numbers the offset is below the true pitch 
of the sound. 

=Pm=y~M==od=e~o~p=tl=on~ _____________ ~ 
The Play Mode options change the way the sound waves are 
played. There are three methods: Looped A&B, One Shot 
A&B, One Shot A & Looped B. As discussed before there 
are actually two waves per sound. Usually the two waves are 
identical and played simultaneously. However, with these three 
modes you have several other options. 

Looped A&B mode plays both waves A and B at the same time 
and when the wave is played through one time (usually taking only 
fractions of a second) the computer loops back and plays it over 
again. This will allow you to use a short sound wave and yet ij can 
sustain a long time for long notes. 

One Shot A&B mode plays both waves A and B at the same time 
but plays ij only one time. This method is good for very long sound 
waves (Le. wave size of 32768 bytes). The quaUty of the sound is 

" usually greatly improved with long waves, however, they usually 
are too long to loop using LOOPED A&B method. Therefore, 
choosing ONE SHOT will provide a good quaUty sound but it can 
not be sustained for long notes. 

ONE SHOT A & B 

.. ~~ 
Wave B 

7-5 



7-6 

One Shot A and LOQped B provides a unique technique for 
playing two sound waves. The attack of a sound wave is usually 
very different than the sustaining and decaying portion of the 
sound. If you want to loop a sound wave with such an attack you will 
end up replaying the attack part of the sound many times while the 
sound is being held for long notes. The One Shot A & Looped 
B mode gets around this problem. If you put only the attack part of 
the wave in Wave A and put only the sustain part of the wave in 
Wave B this roode will work well. Wave A wiD only play one time, 
therefore playing the attack part of the sound, then Wave B will loop 
until you release the note thus playing the sustain part of the note. 

ONE SHOT A & LOOPED B 

In the figure above the attack is Wave A and the sustain part of the 
sound is stored in Wave B . 

• Lacped A & B 

o One SOOIA & B 

o an. Shot A & Looped B 

( Q( ) 

To change the Play Mode click on the desired mode and click 
OK. 

ChapterS 
The Sampler Menu 
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~T~h~e~S~am~p~w~r~M~e~n~u~ ___________ ,~ 
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The Sampler menu contains commands that use a digitizer card 
such as MD Ideas Stereo Card with Digitizer. There is only one 
Sampler command. 

Record Reads the digitizer card and stores the resuft 
(sample) in memory as Wave A, Wave S or both 
Wave A & Wave s. 

=~==o=r=d~____________________~ 
The Record command is used to read sound samples from a 
digitizer card such as MD Ideas Stereo Card with Digitizer. Sounds 
are played into a microphone and turned into digital values and 
stored on the Instrument Designer as a wave on the Wave Sound 
window. 

The Sampler menu has only one menu item. It is called Record. 
The Record command is used to record or read a sound as it is 
played into the microphone. To use Record: 

1 Select Record from the Sampler menu. 

2 A dialog will display that indicates which wave the sample will be 
written to. Your choices are Wave A. Wave S or Wave A&S. 

3 A Recording dialog box will display: 

Digitizer Slot ; 1 

Samples per second ; 27.5 

( Start ) (Cancel) 

From the box you should setup the following things: 

• Digitizer Slot - Indicates the slot in which the digitizer 
card is located . 

• Sample Rate - Indicates the number of data points read 
per second. The higher the number of data points the 
more accurate the reading. The lower the data points the 
longer the sample. 

To change any of the above settings. simply Click on the 
number to the right of the equal sign (;). Every time you click 
on a number it will change to the next valid value. 
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3 To begin recording click on the Start button. Once clicked 
you will have only a few seconds to record the sound. 

The digitized sound will be recorded and written to the 
Sound Wave window. 

4 Unless you began your sound exactly when you clicked the 
Start button (which is very unlikely), you will need to Cut the 
silent portion of the recording found at the beginning of the 
sound wave. r " ... "dlng .......... 

+ 

'- CROP thII portion at the aarrpIe 

The Cut feature is found on the Edit menu. (Refer to Chapter 
4 - Edit Menu for details) 

Recording Hints 

8-4 

Prior to recording a sound you should decide what play mode you 
will be using. If you use a LOOPED A&B mode, you should plan on 
using a short wave. Usually you will want a sarTllle that has only one 
cycle in it. 

This is one cycle of the sound wave. 

Sound waves are only stored in memory in sizes that are rnuttiples 
of 256 bytes. If you want to create a short wave that is 256 bytes. 
Try the following: 

1 Set the Wave Size to 1024 bytes. 
2 Record the sound. 
3 Display wave in 100% mode. 
4 Find one good wave cycle and crop all but that cycle. 
5 If the wave cycle is longer that 256 bytes, re-sample with a 

higher frequency. If the wave cycle is shorter than 256 bytes, 
re-sample using a lower frequenycy. 

6 Set the Wave Size to 256 bytes. 

If you want to create a sound that has no sustain such as guitar, 
piano, bells, etc. you will probably use ONE SHOT A&B mode. 
With this mode you should take as long a sample as possible. 

1 Set the Wave Size to 32768 bytes. 
2 Record the sound. 
3 Display wave in 100% mode. 
4 Cut the dead space from the beginning of the sound. (This is 

the recorded part before the sound began.) 
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-,,!M~ID~I Tr~o!..!:!u~b~le2!sh~oo~tin~g _____ ,~ 
If your MIDI record or play is not operaUng check the following: 

• Your computer must have at least 512K Free RAM. The 
RAM must be free and not used as RAM Disk. This 
information is found on your AppleJlGS Control Panel. (See 
AppieliGS Owne(s Guide) 

• Slot 7 of the computer must be set to Your Card. This 
information is also found on the AppleJlGS Control Panel. 

• 

• 

• 

Appendix-2 

If you are using a MIDI interface card that plugs into a slot 
inside the computer, use slot 2, and set Slot 2 on the 
AppleJlGS Control Paneito Your Card. 

If you are using a Casio HT700 synthesizer, you must always 
select one of the program buttons (piano, harpsichord, etc.) 
before each transmission when using the Apple MIDI Box. 

Your AppieliGS must have the 2.0 ROM. If the first 3 digits of 
your serial number are less than 704 the you probably need 
the 2.0 update. Your local Apple dealer can install this 
update for you at little or no charge. 

Installing Instrument Designer 
on hard disk 

The version of PRODOS and Apple system tools installed on your 
hard disk may be different version from those that the Instrument 
Designer can work with. You may need to copy Pro Dos and Apple 
system tools found on the Instrument Designer program disk to 
your hard disk. H this prevents other programs from working you will 
have to recopy the current versions back to the disk when you want 
to run those programs. 

1 After starung the AppieliGS finder, insert the Instrument 
Designer into the disk drive. 

2 Drag the following Instrument Designerdocument 
INSDESIGNER.SYS16 to the hard disk icon: 

3 On the hard disk, rename InsDeslgner.SYS16 to 
INS DESIGNER. 
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Making Data Disks ~ Index ~ 
To make a data disk for the sound files created by the Instrument clipboard 4-3 Sample rate 8-3 
Designer: Close command 3-4 Sampling hints 8-4 

Copy command 4-5 Save dialog 3-5 
1 Insert the ApplellGS System Disk and turn on the computer. Cut command 4-5 Save As command 3-5 

data disks apncix-4 Select button 5-4 

2 Double-click on SYS.UTtLS folder. De-Tuning 2-2 selecting ranges 4-3 
De-Tuning window 5-11 shortcut keys 4-4 

3 Double-click on SYSUTIL.SYSTEM application. Delete command 4-6 Size To Fit option 7-3 
Design Methods 2-3 Snapshot Envelope 6-2 

4 Select Format a Disk. 
Digitizer slot 8-3 Sound Wave 2-2 
Draw button 5-4 Sound Wave window 5-3 
Edit Menu 4-2 Stop button 5-12 

5 Remove the Apple IIGS System Disk from the disk drive. Envelope 2-2,2-6 Support 1-4 
Envelope examples 5-6 sustain loops 5-5 

6 Insert a blank or scratch disk into the disk drive. Envelope menu 6-2 Vibrato 2-2 
Exchange snapshot 6-3 Vibrato window 5-11 

7 Select the slot and drive of the disk you want to format. Envelope window 5-5 Volume window 5-12 
File Menu 3-2 Windows menu 5-2 

The first 3.5" drive is usually slot 5 drive 1. Get Wave File 3-6 Wave A & Wave B 5-3 

The second 3.5" drive is usually slot 5 drive 2. hard disk apndx-3 Wave size option 7-3 

The first 5.25" drive is usually slot 6 drive 1. Instrument DeSigner 2-2 100% Wave option 7-3 
Keyboard window 5-4 

8 Select ProDos operating system. 
Librarian 3-6 
Looped A&B 7-5 

9 Enter DATA for the volume name (the delete key will back up) 
Looped Mode 2-4 
MIDI apndx-2 

and press return. New command 3-3 
One Shot A&B 7-5 
One Shot Mode 2-3 
One Shot A & Looped B 2-7,7-6 
Open command 3-3 
Open dialog 3-3 
Options menu 7-2 
Paste command 4-6 
Play Mode option 7-5 
Quit command 3-8 
Record 8-3 
Relative Pitch option 7-4 
Revert to Snapshot 6-3 
Sampler menu 8-2 
Sample 8-3 
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